Failing to correctly import data (Update Table) while using templates

First off, before going to the problem, a suggestion. The Excel templates don´t have the options from the List Type fields. This is problematic when you have lots of options in a field as you have to re-type them at Excel and that creates the danger of a minor misspelling or difference in capital/non capital letter, etc.

Therefore, if not possible to save the lists as Excel Data Validation (I think you CAN do it, as Jestor does saves Option 1, Option 2, Option 3 at those fields), at least give the users lists in another tab, so the user can himself copy and paste the text at the Excel data validation.


Ok, now to the question at hand

This is the Template Table downloaded from Jestor

Notice the DEPARTAMENTO column. It’s filled. Each of those corresponds to a Department created at Jestor, where the department name is the Column ID.
image

But for some reason, only 6 out of over 50 records, imported the Department


I also imported the Inherent Risk Analysis… it failed to populate the imported template

template. The last column refers to the number of the Risk (it’s id)

Probabilidade and Consequência are also related fields, so I can pull, in a calculated column, other data about those options.

Ok, it’s extended holiday today in parts of Brazil because of Corpus Christi holiday that fell on a thursday.

So I played a little more and solved some of the import issues in one of the tables.

First off, beware of using emojis, colored squares, etc. Because when importing, you will have to use those too (because they count as characters)

So, as my linked records had colored squares, I had to copy the text from Jestor manually to Excel, to the colored field character would also be copied. This is what I got

and lo and behold, when importing back to Jestor, I got correct related fields.
image

Now, my second problem with the Inherent Risk table was that it’s link to the RiskMain table was not working.

The main risk ID is a simple number.

The same number in Excel, when importing to Jestor DOES NOT create the link.

I tried converting the numbers in Excel to text format. Didn´t work.

I tried them as general format. Didn´t work.

With number format. Didn´t work.

So I created a Jestor REPORT, exported the table with a few links to RisksMain I created at random to XLS format. Opened the report and copied the fields.

The simple numbers links from the Jestor report
image

copied to the Jestor Excel template … first 4 numbers only (56, 55, 10 and 43… do you see any difference to the rest???)
image

Even so, the numbers were still not read/imported as ids and thus related records

if anyone can help me on why the numbers are not being imported as related records, I would be very glad.

Hi @RogerPenna

I just sent it to the team to review, we’ll let you know as soon as they return :slight_smile:

Thanks. It’s weird.

When creating records in both the Risks Main and Risks Inherent Analysis, just typing (not selecting) the Departments or Numbers, already links to the other tables.

But when importing, in the RIsksMain, the departments don´t even show… like if they were empty.

And in the Inherent Risk Analysis the numbers are there, but they don´t link. I will be doing some other tests, including creating a new table instead of updating.

EDIT

Just tried some stuff with the Inherent Risk Analysis.

1 - removed the table formating. I doubted it could be it, but still removed for testing. Still did not work

2 - copied the content to Google Sheets and tried importing from Google Sheets.
Also did not work.
Alas, it’s important to notice that Jestor already doesn´t recognize the related records links before importing, at the step where you must tell what is the ID column.

EDIT

3 - tried to import it as a new table. Doesn´t work because New Table import doesn´t allow connectinc records, so the column with foreign keys is really read as “numbers” only.

Ok.
Update

I solved the RisksMain table update problem by creating a new table that was equal to the other one. I could not duplicate it, because I got an error message when trying to duplicate it (notice I could not edit records in it anymore too!)

When I created the new table, the import was flawless, the Departments were correctly linked to the Departments table.

Did the same with the Inherent Risk table.

In the match columns window of the import, it SHOWS it recognizes the numbers as links to the Risks table.

HOWEVER, when the import happens, the column is blank.

Just to show what I said above.

Import screen (both with Update Load Only New; Update Create New Records and Update Only)

wow, it will work…

and then… bummer, it didnt

sorry, I don´t want to use this as a blog about my experiments, but I guess that informing precisely the issues may have the dev team.

So, I created 3 columns of the type Connect Record… all connected to the same Risk Repository table.
In the Risk Repository, I made the name of the Risk the LABEL

Then, at the Excel file, I created all those new connected columns and filled them… two with the ID of the connected records and one with the label.

Here the Import screen… Jestor DID recognize all three Connected Records columns and matched them!

And yet… Inherent Risk Table… with the 3 new columns after importing… all the three are empty!

Hi @RogerPenna

We are very sorry that you are experiencing some issues when trying to import your data! We really appreciate all the details, it really helps us to understand better and fix it!

I’m following the team responsible for analyzing this problem, and I’ll let you know as soon as they solve!

For now I will use UiPath to copy the links from the spreadsheet to Jestor.

Hopefully, such problems can be avoided in future imports I make. Thanks Marcos.

1 Like

Hey @RogerPenna

We are uploading a fix in the importer. Now it should work, but you’ll have to download a new template because it was generating without the field ids.

Another thing for you to be aware of and to take care of is when the value of a connected field is a number, because at the time of searching, it may be that the record comes with the id equal to the value that you passed.
And if you have emoji on the connected record related to the import, it won’t find the record.

1 Like