Can't import a google spreadsheet as a new table

Hello,

Already saw other similar topics and already tried suggested solutions (clear cache and try again).

I’m trying to import a Google Spreadsheet as a new table but even waiting some hours, it won’t show the confirmation on “For You > Notifications”. Just to confirm that I saw the columns and made the type match for each column and run de import feature.

What else can I do?

Hey @samuelbatista could you tell us your ORG.jestor.com and send a template of the sheets you’re trying to import? You can send to hello@jestor.com

@samuelbatista our team uploaded a fix for this issue tomorrow. Did you try to import again? Could try and report to us please :slight_smile:

Hey @marcos.figueiredo

I’m using samuelbatista.jestor.com
What should I inform to hello@jestor.com besides the template?

And just to confirm, tried to import today at 1PM (Brazil) and tried once again 15 minutes before creating this post (right after cleaning browser cache).

Thanks in advance

@samuelbatista just a template of your main spreadsheet. You can send us with sample data if you prefer

Ok! Just sent the template with some sample data.

Thank you

1 Like

Hello,

I’ve just received those error messages on my “For You > Notifications”.

Any ideas?

Hey @samuelbatista thanks for showing us the errors, this helps a lost!

Our tech team is asking if your gmail account that you’re connecting and selecting the spreadsheets is a corporate email? Do you have all the permissions on this email? Is the same that you created you jestors account?

Looks like is @logaroo. Can you confirm that you have all the necessary permission in this email as the google sheets, drive etc to use it to import data?

That’s correct, @logaroo is my professional e-mail and I gave all necessary permissions. Should I tray again?

Could you please try again @samuelbatista ?

Just did! Waiting for it to process

Still can’t import from Google Spreadsheet, error message below:

Error create import config: {"table":"pedidos","tableName":"pedidos","csvFilePath":null,"error":"Client error: GET https://sheets.googleapis.com/v4/spreadsheets/1RDA4ONR7oTXTEa_5H1s95RtfAYWFQ0xEvEOKgPkCIN4?key=AIzaSyBvdt4t3s7Ywg-bDjiBKpGpzINCjWeSaSc`

Also tried to import from CSV File and still waiting for any notification, template still the same I sent to hello@jestor.com

Thanks in advance

@samuelbatista could you please revoke the permissions on Google and then Connect your account again on jestor?

https://myaccount.google.com/u/4/permissions?continue=https%3A%2F%2Fmyaccount.google.com%2Fu%2F4%2Fsecurity%3Fhl%3Dpt_BR&hl=pt_BR

Ok! Just revoked but this time I’m connecting to my personal account.

Now I’ll wait :slight_smile:

Still no sign of data imported (no error and also no success)

@samuelbatista could you add hello@jestor.com as a user for our team to investigate better what’s happening in your account?

Ok! Just added to the team

Hey @samuelbatista we ran some test and the importation was fast and successful as you can see here:

Could you show us which steps you’re doing to import?

You can send us a video showing everything if you prefer. Just send to hello@jestor.com

Ok, just tried again following those steps:

  1. Importar dados
  2. Google Planilhas
  3. Escolha um tipo de conexão: Migração - Importe seus dados e crie uma nova tabela
  4. Checklist de importação e login com Google: Todos marcados
  5. Selecionar conexão
  6. Selecionar planilha
  7. Selecionar uma tab
  8. Validar campos: definir nome da tabela
    8.1 Coluna 1: id - Use-o como um campo…
    8.2 Coluna 2: Loja - Lista e fases com 1 opção
    8.3 Coluna 3: Distâcia (KM) Número
    8.4 Coluna 4: CEP - Número
    8.5 Coluna 5: Bairro - Lista e fases com 1 opção
    8.6 Coluna 6: Logradouro - Texto curto
    8.7 Coluna 7: NÚmero - Número
    8.8 Coluna 8: Pagamento - Lista e fases com 1 opção
    8.9 Coluna 9: Canal de Vendas - Lista e fases com 1 opção
    8.10 Coluna 10: Valor - Número
    8.11 Coluna 11: Criado em - Data e Hora
  9. Concluir migração
  10. Processos de migração concluído

I’ve always followed those steps but wasn’t receiving any notifications or having success/